TekTerm J106j - I117n F5 sends esc signal

TekTerm J106j - I117n F5 sends esc signal

This question is answered


I have a problem with using function keys in TekTerm application from version J106j to I117n.

Parameters used (the important ones):

Connection Type: Telnet
Terminal Type: VT220
Function Key Remap: No
Arrow Key Remap: No
Host Character Set: Lower:ASCII ISO-IR 006 Upper: Latin 2 ISO-IR 101

When I use F5 to open propertie of some object the esc signal gets me back to a previous form, and then the F5 signal is sent.
From the server end everything is working as it should, using a computer terminal application.

When a do a remap (inside TekTerm) on the F5 to act like a F6, pressing F5 button gives me the F6 signal but does not send an esc signal. So I think the problem it is somewhere inside the TekTerm application.

Please help.

Verified Answer
All Replies
  • Hello Miroslav ,

    It is quite possible that there is an error in that versions of Tek term .

     Have you tried the recommended level?

    Both Tek term versions that you mentioned are very old.




    Help Desk

  • Hi,


    I am wondering what Host application you are using ?

    Is it Sapconsole with Georgia or Seatle Labs Telnet Server?

    In that case you need to remap F5.

    Let us know if you need the correct hex code string for remapping F5 for Sapconsole ?


    Best regards,



  • @Lana

    I am working in Serbia, and the former is the latest version I am geting from my reseller.


    Its a custom build terminal application that we are producing. We had no problems with other terminal emulations (ie. Wavelink).

    Give me the hex code string for remapping (or multiple if you have them) so I cat test that.

    Thanks for the help.

  • functionkeymapping.5     1B,5B,33,35,7E,00,00,00

    The provider of the custom built application should know the correct codes.

    You could take a network trace to see what the other terminals are really sending.


  • Sascha,

    That did not fixed the problem. The problem is not the wrong code that Tek Term is sending, but the escape caracter before the code.
    The code for F5 is good, and it is like on the other terminal emulators, its just that it sends escape before that and it automaticly exits the form I am in.

    We can map enything that the device is sending to be F5 on the application side, but it sends escape which we can not hendle.

  • ESC Delay
    Clients will send escape sequences on certain occasions. For example when a function or arrow key is
    depressed a sequence of data is transmitted that starts with the escape character (0x1b). When the escape
    character is received, the server must determine if this escape is part of an escape sequence or simply an escape
    key. Servers use the ESC Delay value to determine how long to wait for the next character after an escape
    is received to consider it part of an escape sequence. If a character is not received within this time then the
    escape is considered to be a escape key, otherwise it is the start of an escape sequence.

    If you see that escape sequences are not
    going through and being displayed on the screen rather than being interpreted. For example if you type F10
    and see odd character starting with "]" or "[". This is most likely to happen with terminal servers or other slow
    links like RAS. 

  • Hello ,

    I did some research here and I found that :

    If you check this out:


    Notice that the vt-220 keyboard has no F5 key?

    The MS telnet, sends for the F5 key the string “Esc[15~" (hex value 1b 5b 31 35 7e)

    Now, Tekterm (doesn’t matter if it is running on the PC or the WAP), sends the string " Esc[16~"

    Try remapping F5 key under ANSI Telnet Tek term settings to 1b 5b 31 35 7e and test it .


    Kind regards ,




  • Could it be they use 8 bit Ascii?


    7 Bit Escape Sequence

    8 Bit Escape Sequence






    Line Feed










    Backspace (Delete)















    Back Tab


    1B 5B 5A


    9B 5A

    Up Arrow


    1B 5B 41


    9B 41

    Down Arrow


    1B 5B 42


    9B 42

    Left Arrow


    1B 5B 43


    9B 43

    Right Arrow


    1B 5B 44


    9B 44

    VT PF1


    1B 4F 50


    8F 50

    VT PF2


    1B 4F 51


    8F 51

    VT PF3


    1B 4F 52


    8F 52

    VT PF4


    1B 4F 53


    8F 53



    1B 4F 4D


    8F 4D



    1B 5B 31 37 7E


    9B 31 37 7E



    1B 5B 31 38 7E


    9B 31 38 7E



    1B 5B 31 39 7E


    9B 31 39 7E



    1B 5B 32 30 7E


    9B 32 30 7E



    1B 5B 32 31 7E


    9B 32 31 7E



    1B 5B 32 33 7E


    9B 32 33 7E



    1B 5B 32 34 7E


    9B 32 34 7E



    1B 5B 32 35 7E


    9B 32 35 7E



    1B 5B 32 36 7E


    9B 32 36 7E

    F15 / Help


    1B 5B 32 38 7E


    9B 32 38 7E

    F16 / Do


    1B 5B 32 39 7E


    9B 32 39 7E



    1B 5B 33 31 7E


    9B 33 31 7E



    1B 5B 33 32 7E


    9B 33 32 7E



    1B 5B 33 33 7E


    9B 33 33 7E



    1B 5B 33 34 7E


    9B 33 34 7E



    1B 5B 31 7E


    9B 31 7E

    Insert Here


    1B 5B 32 7E


    9B 32 7E



    1B 5B 33 7E


    9B 33 7E



    1B 5B 34 7E


    9B 34 7E

    Previous Screen


    1B 5B 35 7E


    9B 35 7E

    Next Screen


    1B 5B 36 7E


    9B 36 7E

  • @Lana

    Yes, that is the problem, I see now. The emulation we are using is the problem. There is no fixing that (I tried your maping, did not help), so I did it litle weird:

    I maped F5 inside the TekTerm to F11, then I maped F11 to be F5 on the application server.

    It's not briliant solution, but the F5 key is usable again,  and the best part is the clients did not notise any diference in their work.

    Thanks a lot for the help!

  • You are very welcome .